Network Provider Outage
Incident Report for Arctium Service
Resolved
This incident has been resolved.
Posted Mar 27, 2024 - 16:04 UTC
Investigating
Our network provider has some major issues at the moment. This might result in connection issues to all services
Posted Mar 27, 2024 - 15:00 UTC
This incident affected: In-House Hosting, Arctium App API, and Web.